commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brett Porter <br...@apache.org>
Subject Re: [site] problem maven site'ing
Date Fri, 03 Feb 2006 22:28:04 GMT
Are you using JDK 5 or 1.4?

Maven 1.1 uses your built in XML parser. Problem is, the two JDKs behave
completely differently. I think we need to go back to bundling xerces.

- Brett

Henri Yandell wrote:
> On 2/3/06, Dennis Lundberg <dennisl@apache.org> wrote:
>> Henri Yandell wrote:
>>> I get the following error when doing "maven site":
>>>
>>> Error on line 17 of document  : Relative URI
>>> "../../commons-build/menus/menus.dtd"; can not be resolved without a
>>> base URI. Nested exception: Relative URI
>>> "../../commons-build/menus/menus.dtd"; can not be resolved without a
>>> base URI.
>>>
>>> Any idea whats up?
>> What component are you building the site for?
> 
> 
> I get the same error on both [cli] and [lang].
> 
>> If you send me the "Installed plugins:" section of
>>    maven --info
>> I can help you debug.
> 
> maven --info:
> 
> Installed plugins :
>   cactus-maven-1.7.1
>   maven-abbot-plugin-1.1
>   maven-announcement-plugin-1.3
>   maven-ant-plugin-1.9
>   maven-antlr-plugin-1.2.1
>   maven-artifact-plugin-1.5.2
>   maven-aspectj-plugin-3.2
>   maven-castor-plugin-1.2
>   maven-changelog-plugin-1.8.2
>   maven-changes-plugin-1.5.1
>   maven-checkstyle-plugin-2.5
>   maven-clean-plugin-1.3
>   maven-clover-plugin-1.10
>   maven-console-plugin-1.1
>   maven-cruisecontrol-plugin-1.7
>   maven-dashboard-plugin-1.8
>   maven-developer-activity-plugin-1.5.2
>   maven-dist-plugin-1.6.1
>   maven-ear-plugin-1.7
>   maven-eclipse-plugin-1.9
>   maven-ejb-plugin-1.7.1
>   maven-faq-plugin-1.5
>   maven-file-activity-plugin-1.5.2
>   maven-genapp-plugin-2.2.1
>   maven-gump-plugin-2.0.1
>   maven-hibernate-plugin-1.3
>   maven-html2xdoc-plugin-1.3.1
>   maven-idea-plugin-1.6
>   maven-j2ee-plugin-1.5.1
>   maven-jalopy-plugin-1.3.1
>   maven-jar-plugin-1.7
>   maven-java-plugin-1.5
>   maven-javacc-plugin-1.1
>   maven-javadoc-plugin-1.7
>   maven-jboss-plugin-1.5
>   maven-jbuilder-plugin-1.5
>   maven-jcoverage-plugin-1.0.9
>   maven-jdepend-plugin-1.5
>   maven-jdiff-plugin-1.5
>   maven-jellydoc-plugin-1.3.1
>   maven-jetty-plugin-1.1
>   maven-jira-plugin-1.1.2
>   maven-jnlp-plugin-1.4.1
>   maven-junit-report-plugin-1.5
>   maven-jxr-plugin-1.4.3
>   maven-license-plugin-1.2
>   maven-linkcheck-plugin-1.3.4
>   maven-multichanges-plugin-1.1
>   maven-multiproject-plugin-1.4.1
>   maven-native-plugin-1.1
>   maven-nsis-plugin-1.1
>   maven-pdf-plugin-2.4
>   maven-plugin-plugin-1.6
>   maven-pmd-plugin-1.7
>   maven-pom-plugin-1.4.1
>   maven-rar-plugin-1.0
>   maven-release-plugin-1.4.1
>   maven-repository-plugin-1.2
>   maven-scm-plugin-1.5
>   maven-simian-plugin-1.5
>   maven-site-plugin-1.6.1
>   maven-tasklist-plugin-2.4
>   maven-test-plugin-1.7
>   maven-uberjar-plugin-1.2
>   maven-war-plugin-1.6.1
>   maven-xdoc-plugin-1.9.2
>   maven-xdoclet-plugin-1.2.3
> 
> It's a maven 1.1-beta2 install, with the commons plugins install script run.
> 
> Hen
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: commons-dev-help@jakarta.apache.org
> 

---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message