commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Niall Pemberton <niall.pember...@gmail.com>
Subject Re: [all][POLL] What JDK Version are you using?
Date Thu, 26 Jan 2006 11:09:33 GMT
On 1/23/06, Thomas Dudziak <tomdzk@gmail.com> wrote:
> On 1/23/06, Emmanuel Bourg <ebourg@apache.org> wrote:
> > James Carman wrote:
> > > Struts is probably your biggest contributor of users, so that's a good sign
> > > for your 1.4 requirement.  However, I would still be cautious.  Not all
> > > users subscribe to the mailing lists.  I would doubt that it's a high
> > > percentage at all.
> >
> > Even if all users aren't subscribed it's likely to give a good sample of
> > the issues involved in jumping to a higher JDK.
> >
> > I bet the issue with old installations of WebSphere 4/5 will be the most
> > frequently reported...
>
> IMHO the only way around this is to create a branch for the old
> version (validator in this case) and maintain it for users forced to
> use 1.3. Maintain meaning backporting mainly the important bug fixes.

I agree that branching is a good idea and will do this if we move to
JDK 1.4 - the reality is though that active validator committers are
thin on the ground and the likelihood of me back porting is not high
since I don't have a need for JDK 1.3

Niall

> Tom

---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message