commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daniel F. Savarese" <...@savarese.org>
Subject Re: [net] JSSE classes in FTPS WAS Re: [net] FTPS submission - legal issues
Date Tue, 24 Jan 2006 20:50:47 GMT

In message <ce1f2ea80601231815u2e4261a4pbfb5d747496d5239@mail.gmail.com>, Rahul
 Akolkar writes:
>No, haven't had to deal with such a situation. But doesn't this mean
>that the code will only work on a subset of the 1.3 JDKs (Sun)? If so,
>maybe (3) isn't all that bad?

In general, I am biased against introducing dependencies on com.sun packages
for the very reason stated.  The code will work only with the Sun JDK or
JVMs incorporating sublicensed parts of the JDK that include those packages.
For that matter, it will work only with a particular version of the Sun JVM
should the classes not appear in a future release.  If JSSE will work and
is usable with JDK 1.3 as an add-on jar, I don't see any reason why it
should be avoided (i.e., I'm +1 for option 3 and -1 for 2).

daniel


---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message