commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 38117] - [configuration] XMLConfiguration contructor not loading the resource
Date Mon, 16 Jan 2006 20:40:56 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=38117>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=38117





------- Additional Comments From oliver.heger@t-online.de  2006-01-16 21:40 -------
(In reply to comment #2)
> 
> Exception detailed message is :
> org.apache.commons.configuration.ConfigurationException: Cannot locate
> configuration source ExceptionHandler.xml
> CAUSE is null
> STACKTRACE is null 

Are you sure the stack trace is null? This is not very useful :-(

Okay, I stepped through the code, but could not find anything, which seems
obviously wrong. The only location where the exception you receive is thrown is
in AbstractFileConfiguration.load(String). This method should not be called at
all when the constructor that takes an URL is used!

Are you able to load configuration files from URLs that point to the file system
or to the same jar file (i.e. does the URL-constructor work for easy cases)? In
our unit tests such cases do work.

Last, but not least: Do you really use the newest version of configuration
(1.2)? In 1.1 there were some bugs related to file based configurations.

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message