commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Niall Pemberton <niall.pember...@gmail.com>
Subject Re: [VOTE] Release Configuration 1.2
Date Thu, 01 Dec 2005 09:35:47 GMT
On 12/1/05, Nicolas De Loof <nicolas.deloof@capgemini.com> wrote:
> >> Can't this dependency be solved using jdbc2.0-stdext.jar ? I'm using
> >> Jdk 1.3 and cannot upgrade. Not supporting 1.3 anymore will stop my
> >> migration to commons-configuration.
> >>
> >> Nico.
> >>
> >
> > Yes, with jdbc2.0-stdext.jar commons-configuration can be compiled and
> > run under a JDK 1.3.
> >
> > Unfortunately this jar cannot be distributed via ibiblio because of
> > licence issues, which makes the build a bit unconvenient. But I guess
> > I will have to update the pom to declare this dependency because
> > DatabaseConfiguration needs the DataSource interface. Would be a good
> > idea to update documentation in this respect, too.
> >
> > Oliver
>
> AFAIK, other apache projects require sun jars to compile. You may ask
> commons-dbcp commiters that seem to have the same requirement :
> "
>    <!-- Note JDBC 2.0 is a pain, because it must be manually
>         downloaded to your Maven repository, and it's not even
>         required on JDK 1.4.  Maybe we should remove it from
>         this dependency list so Maven doesn't choke?
>    -->
>    <dependency>
>      <id>jdbc</id>
>      <version>2.0</version>
>    </dependency>
> "

It would be neater if something could be done in the maven.xml to
detect JDK 1.3 and add it into the class path from a property
specified in the build.properties. I'm going to face the same issue in
Commons Resources - we have 1 class that relies on JDBC 2.

Niall

---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message