commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mario Ivankovits <ma...@ops.co.at>
Subject Re: [net] Minimum jdk/jvm version for net ( future ) ( was: Re: [vote][net] Release commons-net 1.4.1? )
Date Sat, 03 Dec 2005 18:31:00 GMT
Steve Cohen wrote:
> We need to discuss this further.
> Mario Ivankovits VFS is a client of Net and he has users still on 1.3 
> who are complaining that Net 1.4 breaks VFS.
And not only my users constantly complain about it. AFAIK this is also 
true for other commons components.
Though, there is an end of live for jdk1.3 and so we sould also to 
define such a point in the future.

Personally I see this point reached in 6 months, but understand if we 
have to stick on 1.3 for the next year.

Then we should jump to jdk 1.5 (with jdk 1.4 api) and use retroweaver to 
provide the jdk 1.4 version.
Our releases should then contain jars for both (1.5 and 1.4)
I know there are the same issues with api compatibility, but if we run 
our tests against both jdks we should be fine, also it might be possible 
to have an api checker which will check the generated classes against 
the classpath.
Whatever, we might find a way to archive this.

I know, this is somehow radical, but our code starts to smell and become 
spider webs if we have to stick on 1.3 for the time being ;-)

---
Mario


---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message