commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mario Ivankovits <ma...@ops.co.at>
Subject Re: [vote][net] Release commons-net 1.4.1?
Date Fri, 02 Dec 2005 06:51:40 GMT
Steve Cohen wrote:
>
> The thread Robert refers to has the subject
>
> "Re: Does Apache have agreement to use other open source code outside 
> of Apache?"
Has this something to do with an email from IBM in the last few days 
asking me if I am really was the creator of my contributions?
Not that I made any mistake (I guess this was a mail to all commons-net 
developers), but I was a little bit irritated.

> Which is just as well.  Because I have another issue.  I don't 
> understand the maven.compile.target property.  Working from the net 
> 1.4.0 tag, I change only project.properties to set 
> maven.compile.target back to 1.2.  Since there are a few places in 
> 1.4.0 that depend on jdk 1.4, my expectation was that changing the 
> project properties would cause the compile to break on those places.  
> But it did not.  It compiled successfully.
The jdk1.4 compiler creates a class file suitable to run under an 
earlier JVM, this works as long as you do not use any new api. Then 
you'll get the NoSuchMethod Exception.
This is the reason why we should use the least possible compiler and not 
only the target attribute. You didnt notice if you use any new api call 
at compile time.


---
Mario


---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message