commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 37894] New: - [codec] Using US_ENGLISH static in Soundex causes NPE
Date Tue, 13 Dec 2005 22:29:57 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=37894>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=37894

           Summary: [codec] Using US_ENGLISH static in Soundex causes NPE
           Product: Commons
           Version: 1.3 Final
          Platform: PC
        OS/Version: Windows XP
            Status: NEW
          Severity: normal
          Priority: P2
         Component: Codec
        AssignedTo: commons-dev@jakarta.apache.org
        ReportedBy: rriser@informs.com


If I generate a soundex like so:
  Soundex.US_ENGLISH.soundex( "Williams" )
I get a NullPointerException.

But if I use the following:
  new Soundex().soundex( "Williams" )
everything works fine.

I think the order of initialization of statics may be to blame.  I'll attach a
test case.

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message