commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From robert burrell donkin <robertburrelldon...@blueyonder.co.uk>
Subject Re: [vfs][VOTE] release version 1.0
Date Mon, 14 Nov 2005 23:00:51 GMT
On Sun, 2005-11-13 at 21:09 -0700, Phil Steitz wrote:
> On 11/13/05, robert burrell donkin <robertburrelldonkin@blueyonder.co.uk> wrote:
> > On Sun, 2005-11-13 at 19:16 +0000, Stephen Colebourne wrote:
> > > Mario Ivankovits wrote:

<snip>

> > > > As far as I know the next NET version will be able to use target 1.3
> > > > again, then I'll revert to use a java 1.3 compiler with maven too.
> > > > Anyway, VFS uses target=1.3 and I use the jdk 1.3 libraries during
> > > > development - so if your setup is correct (xml apis, java crypto, ...)
> > > > it should work.
> > > No. Not necessarily. See
> > > http://jroller.com/page/scolebourne?entry=compiling_for_older_jdks
> > >
> > > I think that the bootclasspath is what you need to solve the inability
> > > to use [net] from 1.3 issue too.
> >
> > +1
> >
> > is this issue covered well enough in the release documentation?
> 
> See the "Check Class File Format" section in
> http://jakarta.apache.org/commons/releases/prepare.html
> 
> Assuming all agree that compilation itself *must* be done on the
> lowest supported jdk, the text there should be updated to make that
> requirement explicit.   I will update the docs if we can agree on a
> reasonable way to do this using maven, as well as ant.

AIUI setting an appropriate bootclasspath would enable a later JVM
(supported by maven) to be used. probably need more research on this but
am having trouble finding the cycles right now...

- robert


---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message