commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From robert burrell donkin <robertburrelldon...@blueyonder.co.uk>
Subject Re: [vfs][VOTE] release version 1.0
Date Sun, 13 Nov 2005 22:24:17 GMT
On Sun, 2005-11-13 at 19:16 +0000, Stephen Colebourne wrote:
> Mario Ivankovits wrote:
> >> The jar was built with JDK1.4. Are targetting only JDK1.4? If you 
> >> target 1.2/1.3, then it is possible that your jar won't work. I 
> >> recommend compiling using the earliest JDK possible.
> > 
> > Sure, but e.g. commons-net 1.4.0 was built with 1.4 too (+target 1.4), 
> > and thus I cant use the 1.3 compiler as the build will fail if I do so.
> 
> Sounds like a new [net] is needed pronto.

+1

> > As far as I know the next NET version will be able to use target 1.3 
> > again, then I'll revert to use a java 1.3 compiler with maven too.
> > Anyway, VFS uses target=1.3 and I use the jdk 1.3 libraries during 
> > development - so if your setup is correct (xml apis, java crypto, ...) 
> > it should work.
> No. Not necessarily. See 
> http://jroller.com/page/scolebourne?entry=compiling_for_older_jdks
> 
> I think that the bootclasspath is what you need to solve the inability 
> to use [net] from 1.3 issue too.

+1

is this issue covered well enough in the release documentation?

- robert


---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message