commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 37034] New: - Loading of resources causes webapp to fail redeploy under Tomcat 5.5.x
Date Wed, 12 Oct 2005 00:06:28 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=37034>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=37034

           Summary: Loading of resources causes webapp to fail redeploy
                    under Tomcat 5.5.x
           Product: Commons
           Version: 1.5 Final
          Platform: Other
        OS/Version: other
            Status: NEW
          Severity: major
          Priority: P2
         Component: Digester
        AssignedTo: commons-dev@jakarta.apache.org
        ReportedBy: rich@apache.org


This was originally filed against Beehive as
http://issues.apache.org/jira/browse/BEEHIVE-960 , but I've narrowed it down to
either a Digester issue or a Tomcat issue.  Tomcat seems to suggest that this is
an issue related to getting resources out of a JAR:
    - http://issues.apache.org/bugzilla/show_bug.cgi?id=33830
    - http://jakarta.apache.org/tomcat/faq/windows.html#lock

Specifically, Tomcat turned off the behavior that prevents locking of JARs under
Windows.  They did this to improve startup time.  I don't necessarily agree with
this choice as a default, but if you believe their bug comments and FAQ, this
actually just exposes Windows-specific bugs in the way resources are read out of
JARs.

To reproduce this:
    - Run 'ant build war' in the attached directory.
    - Copy strutsRedeploy.war into $CATALINA_HOME/webapps.
    - Verify that there is a fully-extracted webapp under
$CATALINA_HOME/webapps/strutsRedeploy.
    - Copy strutsRedeploy.war (again) into $CATALINA_HOME/webapps.

Now look in $CATALINA_HOME/webapps/strutsRedeploy -- it failed to redeploy, and
the only file left in there is WEB-INF/lib/struts.jar.

I'm attaching a Digester patch that fixes the issue.

Note: the fix for this issue belongs in one of three places:
    - Tomcat (which has rejected working around it since it impacts startup time)
    - Digester
    - XML support in the JDK

Hopefully you'll choose Digester.  :)

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message