commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Arnaud HERITIER <aherit...@gmail.com>
Subject Re: [commons-build] Site build problem
Date Tue, 27 Sep 2005 08:17:16 GMT
>
>
>
> This turned out to be a bug in the site.jsl. A patch has been applied
> to svn and this will be fixed in version 1.10 of the xdoc plugin.
> Here is an example site generated using the patched plugin and
> maven.xdoc.theme=classic
> maven.ui.banner.background=#fff
>
> http://people.apache.org/~psteitz/classic.html
>
> The nav entry "Commons Resources (Unofficial)" is too wide to fit (and
> maven.ui.navcol.width seems to no longer do anything); but otherwise
> this looks OK to me. Others may have different opinions; but if this
> looks good enough I would suggest that we tweak the menus, etc. to
> work with this setup and migrate away from using custom style sheets.
> We could get things working right away by just dropping the
> "type='header'" from the About Us menu.
>
> The big advantage of going this route is that we would then no longer
> need to maintain commons-site.jsl, nor to copy the stylesheets out to
> the distributions.
>
> Phil


Can you open an issue for the problem with "maven.ui.navcol.width" ?
We'll fix it (if possible) for the release 1.10

I think you removed the icons used to show "External Links" and "New
Windows". You should remove the legend.
maven.xdoc.legend=false

cheers,

Arnaud

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message