commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Don Brown <donald.br...@gmail.com>
Subject [commons-build] Site build problem
Date Fri, 09 Sep 2005 21:52:13 GMT
It seems this maven problem affects all the commons projects that use the 
commons-build. I'm seeing it on Linux and Windows, both running Maven 1.0.2.

Again, the problem is when running "maven site". When it gets to the jdepend 
report, I see:

xdoc:jelly-transform:
[echo] Generating
/home/mrdon/dev/fileupload/target/docs/jdepend-report.htmlfrom
/home/mrdon/dev/fileupload/target/generated-xdocs/jdepend-
report.xml
Could not find the class: org.apache.commons.jelly.tags.fmt.FmtTagLibrary
java.lang.ClassNotFoundException: 
org.apache.commons.jelly.tags.fmt.FmtTagLibrary
at java.net.URLClassLoader$1.run(URLClassLoader.java:199)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:187)
at java.lang.ClassLoader.loadClass(ClassLoader.java:289)
at java.lang.ClassLoader.loadClass(ClassLoader.java:235)
at org.apache.commons.jelly.JellyContext.getTagLibrary(JellyContext.java
:425)
...
Underlying exception: java.lang.ClassNotFoundException: fmt
java.lang.ClassNotFoundException: fmt
at java.net.URLClassLoader$1.run(URLClassLoader.java:199)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:187)
at java.lang.ClassLoader.loadClass(ClassLoader.java:289)
at java.lang.ClassLoader.loadClass(ClassLoader.java:235)
at org.apache.commons.jelly.parser.XMLParser.createTag(XMLParser.java:1039)
...
Could not create taglib or URI: jelly:fmt tag name: message
java.lang.ClassNotFoundException: fmt
at org.apache.commons.jelly.parser.XMLParser.createSAXException(
XMLParser.java:1234)
at org.apache.commons.jelly.parser.XMLParser.createTag(XMLParser.java:1044)
at org.apache.commons.jelly.parser.XMLParser.startElement(XMLParser.java
:647)
at org.apache.xerces.parsers.AbstractSAXParser.startElement(Unknown Source)
...
Underlying exception: java.lang.ClassNotFoundException: fmt
java.lang.ClassNotFoundException: fmt
at org.apache.commons.jelly.parser.XMLParser.createSAXException(
XMLParser.java:1234)
at org.apache.commons.jelly.parser.XMLParser.createTag(XMLParser.java:1044)
at org.apache.commons.jelly.parser.XMLParser.startElement(XMLParser.java
:647)
at org.apache.xerces.parsers.AbstractSAXParser.startElement(Unknown Source)

Is anyone else seeing this problem? I've tried removing ~/.maven but with no 
luck.

Don

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message