commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joerg Heinicke <joerg.heini...@gmx.de>
Subject Re: [jci] initial compiling
Date Mon, 15 Aug 2005 09:21:24 GMT
Torsten Curdt <tcurdt <at> apache.org> writes:

> > I have a problem with loading a class immediately after the setup  
> > of the CompilingClassLoader. With a setup like in the TestCases using a  
> > signal object it does not work (I get ClassNotFoundException), because the
> > CCL does release a reload() event immediately after setup - before my files
> > have been compiled.
> 
> Why would you expect the classes be available right away?
> It's an asynchronous process. But maybe explain your
> environment a bit more.

That's absolutely clear. I have a setup like in the TestCases with a signal
object waiting for the reload signal. But the first reload signal is released by
the CCL itself without waiting for the compiling. And IMO this is wrong.

> If the files are already on disk the start of the CL
> should start the fam that will trigger the compilation
> after the first run.

Yes, it does. But at the same time it releases a "hasReloaded" event - before it
is actually setup correctly.

> The "hasReloaded" notification should
> happen after the compilation has finished and your classes
> should be available after that.

As I wrote above the first "hasReloaded" happens already by the CCL itself at
the end of its start() method. The second "hasReloaded" is the one to go at the
moment. But this looks more like a bug than a reliable feature.

> Please try the latest version and report back.
> I did some substantial changes over the weekend.

Still the same like on Friday.

Joerg


---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message