commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Carman" <ja...@carmanconsulting.com>
Subject RE: [proxy] Nightly Builds...
Date Mon, 29 Aug 2005 10:53:45 GMT
We (knut and I) have actually been kicking around the idea of making proxy
1.4-enabled, since the type safety of ObjectProviders really isn't a big
boon to the API (it can actually be a nuisance) and the other features that
I use (so far) aren't necessarily necessary (the read-write lock in the
SingletonProvider could be replaced with a simple synchronized block; I got
a bit carried away).  But, if this is something that we need to address
anyway (maybe Maven should be updated so that the project.xml file can tell
it what the minimum JVM requirement is, kind of like webstart), then we
should probably just go ahead and do it.

-----Original Message-----
From: Craig McClanahan [mailto:craigmcc@gmail.com] 
Sent: Monday, August 29, 2005 1:44 AM
To: Jakarta Commons Developers List
Subject: Re: [proxy] Nightly Builds...

On 8/28/05, James Carman <james@carmanconsulting.com> wrote:
> How do I set up Commons Proxy for nightly builds?  Do I have to "gump-ize"
> it?

Nightly builds for most of the Commons Proper and Commons Sandbox
projects are built on my personal desktop machine and then uploaded
(yes, it should really be on ASF hardware somewhere ... nobody has yet
had the time to set that part up).

The basic requirement is that the project be added to the
"commons-trunk" or "commons-sandbox" (as appropriate) svn:externals
property (which I have done), and that an "ant clean dist" in the
package directory will create the relevant artifacts.  Here we have a
problem with proxy, since it appears to require JDK 1.5.  I can't just
switch the version use to compile all the other projects unless they
explicitly declare a "target" attribute in their build scripts (to
avoid creating 1.5 classes that won't actually run in earlier JVMs).

I'll need to do some surgery on my build scripts to take into account
Commons packages that require 1.5 ... it'll likely take a couple of
days.

Craig McClanahan


> 
> 
>

---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org




---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message