commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 35717] New: - tables.table(0).name does not work for XMLConfiguration
Date Wed, 13 Jul 2005 14:22:20 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=35717>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=35717

           Summary: tables.table(0).name does not work for XMLConfiguration
           Product: Commons
           Version: 1.1 Final
          Platform: Other
        OS/Version: other
            Status: NEW
          Severity: normal
          Priority: P2
         Component: Configuration
        AssignedTo: commons-dev@jakarta.apache.org
        ReportedBy: timko@pobox.sk


Hierarchical configuration comment states that XML structure can be handled 
separately element by element (using tables.table(0).name).

XMLConfiguration extends the class, I would expect the same features. However 
it does not work and anytime I provide () values, I receive null. If I want to 
retrieve list of values, I receive collection of all existing fields of all the 
tables and this is not correct as I need to process them separately. After that 
I do not know which field belongs to which table.

Is it a feature or is there any way how to use XMLConfiguration on a smarter 
way?

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message