commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dion Gillard <dion.gill...@gmail.com>
Subject [email] dumbster and jdk1.3
Date Wed, 22 Jun 2005 16:24:03 GMT
Does dumbster need jdk1.4 to build?

We are using dumbster to test commons-email (
http://jakarta.apache.org/commons/email/ ) and when testing under
jdk1.3 dumbster dies, apparently in SmtpMessage.toString() which is
using a JDK1.4 specific StringBuffer method:

[junit] Testcase:
testSendWAttachments(org.apache.commons.mail.SendWithAttachmentsTest):
   Caused an ERROR
[junit] null
[junit] java.lang.NoSuchMethodError
[junit]     at com.dumbster.smtp.SmtpMessage.toString(Unknown Source)
[junit]     at org.apache.commons.mail.BaseEmailTestCase.saveEmailToFile(BaseEmailTestCase.java:128)
[junit]     at org.apache.commons.mail.BaseEmailTestCase.validateSend(BaseEmailTestCase.java:210)
[junit]     at org.apache.commons.mail.BaseEmailTestCase.validateSend(BaseEmailTestCase.java:314)
[junit]     at org.apache.commons.mail.SendWithAttachmentsTest.testSendWAttachments(SendWithAttachmentsTest.j

Would it be possible to get dumbster releases compiled against JDK1.3?
-- 
http://www.multitask.com.au/people/dion/
"You are going to let the fear of poverty govern your life and your
reward will be that you will eat, but you will not live." - George
Bernard Shaw

---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message