commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gary Gregory" <ggreg...@seagullsoftware.com>
Subject RE: [lang] 2.1RC7 and java < 1.4
Date Tue, 31 May 2005 17:49:09 GMT
Hello:

I've finally worked out the oddball build and class loading issue that
only seems to happen on Windows XP (SP2) since Simon reports that the
ant build works fine for him on Linux. 

I can report success with "ant clean dist-build-2.1 test" on Sun Java
versions:

1.5.0_03
1.5.0_02
1.4.2_08
1.3.1_14

In order achieve this; the new build.xml depends on Ant 1.6.

Version 1.2.2_017 hangs miserably for me though, as it did before any of
these changes.

"[alas, it probably means another RC though]."

Yes, please.

Thanks,

Gary

-----Original Message-----
From: Simon Kitching [mailto:skitching@apache.org] 
Sent: Monday, May 30, 2005 12:40 AM
To: Jakarta Commons Developers List
Subject: RE: [lang] 2.1RC7 and java < 1.4

On Sun, 2005-05-29 at 11:34 -0400, Gary Gregory wrote:
>  
> 
> Here is what I propose baring any -1s from others: I'll make the
changes
> noted below while still using the "old" test invocation style for the
> Enum/Enums test. This last class loading problem being a weird one.
Hm,
> now that I think about it the Enum/Enums will still fail on either 1.3
> (no fix: old error; with fix: new class loading problem), sigh. I
guess
> I or someone else should dig into the class loading issue, which only
> happens from the Ant CLI, not when I run the tests from Eclipse.


I'll just note (again) that all the unit tests work FINE for me with the
Ant CLI (and the Maven CLI), on java 1.2.2, 1.3.1, 1.5.0 (all on Linux).

Not that I have any objection to depending on ant 1.6 for builds if
people want to [alas, it probably means another RC though].

Hmm.. one thing I just noticed though. Normally, foo-src.tar.gz files
unpack into a directory named foo-src. But
commons-lang-2.1-RC7-src.tar.gz unpacks into a directory
"commons-lang-2.1-RC7".

Regards,

Simon



---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org



---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message