commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jörg Schaible <Joerg.Schai...@Elsag-Solutions.com>
Subject RE: [logging][httpclient] pb using eclipse
Date Wed, 09 Mar 2005 15:17:08 GMT
Hi Andre,

A Leg wrote on Wednesday, March 09, 2005 3:32 PM:

> Hi Jorg
> 
> I try httpclient in another place and I get a problem too.
> I don't understand and worse I don't find any solution.

[snip]

> {orion:rcs} java -classpath
> $JWSDP_HOME/jwsdp-shared/lib/commons-httpclient.jar:$JWSDP_HOM
> E/jwsdp-shared/lib/commons-logging.jar:$J2RE_LIBRARY/jsse.jar:
> $J2RE_LIBRARY/jce.jar -jar Test.jar
> Exception in thread "main" java.lang.NoClassDefFoundError:
> org/apache/commons/httpclient/protocol/SecureProtocolSocketFactory

Hmmm. Never used httpclient nor jsse so I am unsure about the classloader requirement for
this factory. E.g. an own implementation for java.util.log.Formatter is only found everytime,
if it is located in the system class loader (means also J2SE/lib/ext), but not if your app
has special classloader hierarchy. Same may apply here for this factory for httpclient. Then
you have no choice but stuffing anything into J2SE/lib/ext again.

The problem with Eclipse is, that is uses the Log interface loaded by the classloader of the
help plugin utilizing Tomcat and the Jdk14Logger is found in the system classloader. This
will not work. Part of the problem is also, that the integrated tomcat in eclipse comes with
both commons-logging.jar and commons-logging-api.jar. Try to remove the -api.jar and adjust
the plugin.xml. The other jar has all classes anyway.

- Jörg

---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message