commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mario Ivankovits <>
Subject Re: [VFS] RandomAccessContent
Date Wed, 02 Mar 2005 14:54:44 GMT
Edgar Poce wrote:
> I think org.apache.commons.vfs.provider.AbstractRandomAccessContent 
> should be renamed to AbstractRandomAccessContentRO (ReadOnly) because, 
> as stated in the javadocs, it's a superclass only suitable for read 
> only implementations. In 
> o.a.c.vfs.provider.AbstractRandomAccessContent methods I'd like to 
> find methods with common functionality to all providers, e.g. type 
> conversion both for reading and writing.
Thanks for the suggestion, but this class was meant to be the superclass 
for all RandomAccesContent implementation - at first with some help for 
ReadOnly implementations and later for any implementation. I just have 
to work out their similaries.

> btw, great product!


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message