commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 33866] New: - enum package is not compatible with 1.5 jdk
Date Sun, 06 Mar 2005 04:19:11 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=33866>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=33866

           Summary: enum package is not compatible with 1.5 jdk
           Product: Commons
           Version: 2.0 Final
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P2
         Component: Lang
        AssignedTo: commons-dev@jakarta.apache.org
        ReportedBy: igor@fedulov.com


Classes that are located in org.apache.commons.lang.enum package can't be used 
with 1.5 jdk (aka the 5.0) because the "enum" is a reserved keyword. Compiler 
error looks like this: "as of release 1.5, 'enum' is a keyword, and may not be 
used as an identifier (try -source 1.4 or lower to use 'enum' as an 
identifier)"

There probably should be a separate jar for 1.5+ jdk

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message