commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 33475] - [configuration] [PATCH] ClassNotFoundException on Sun App Server
Date Thu, 10 Feb 2005 14:30:37 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=33475>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=33475





------- Additional Comments From mbcolbert@yahoo.com  2005-02-10 15:30 -------
Hi Oliver,

I ran the unit tests with and without the patch; TestXMLConfiguration failed in
the same way both times at testLoad.  So, I'm unable to tell at this time if the
patch affects the unit tests.  This is using code from CVS.

Regarding other options, I'm open to alternatives.  I am already packaging the
correct jars in the EAR and setting the classpath in the ejb-jar manifest.  This
doesn't solve the problem, though, due to the classloader delegation model. 
Since Digester is already loaded by the System classloader, it will not be
loaded by any child classloaders, such as the EJB classloader.

Again, I'm using code from CVS.  Does this make any difference?  I'm a little
confused about whether to use CVS or SVN here.  CVS doesn't look seem as up to date.





-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message