commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Henri Yandell <flame...@gmail.com>
Subject Re: [lang] 2.1...
Date Wed, 26 Jan 2005 15:43:28 GMT
I've been filling out some tests/overloads in ArrayUtils when I've
found time. Need to commit my latest.

I think we should wait until after the svn change, sounds like it'll
happen pretty soon.

I'm happy to volunteer to do the release management.

Who wants to handle the WordUtils changes?

Hen

On Wed, 26 Jan 2005 00:14:24 -0000, Stephen Colebourne
<scolebourne@btopenworld.com> wrote:
> Checking my mail history
> 
> > Still TODO:
> > 5)
> > - WordUtils
> > Capitalize with separator methods need to define null handling for
> > delimiter
> > list, and better javadoc for two of the three methods
> 
> And thats it, besides finding a volunteer to do the release (before a svn
> change?)
> 
> Stephen
> 
> 
> ----- Original Message -----
> From: "Gary Gregory" <ggregory@seagullsoftware.com>
> Hello All:
> 
> I just noticed it's been about a month since the last 2.1 ponderings.
> Where do we stand now?
> 
> Curious,
> Gary
> 
> -----Original Message-----
> From: Henri Yandell [mailto:flamefew@gmail.com]
> Sent: Friday, December 17, 2004 7:22 PM
> To: Jakarta Commons Developers List
> Subject: [lang] 2.1...
> 
> Sorry for the silence from me. As I've probably said a million times,
> baby happened.
> 
> I'm full of coding energy, or perhaps the need to 'have coded' that
> leads to coding happening and looking to direct some of it to Lang
> 2.1.
> 
> Looking at the wiki and bugzilla, we were nearly there as far as I
> recall. Not a lot has cropped up in the 2 months or so that have
> passed, couple of bugs I've easily closed out and a couple of trickier
> ones.
> 
> Gary seems to have taken care of
> http://issues.apache.org/bugzilla/show_bug.cgi?id=32625. Is it ready
> for closure Gary? Despite Matt Blum's comment on a work-around, it
> still sounds like a fine change to the library.
> 
> The only other new bug is a note on incorrect javadoc and should be an
> easy one: http://issues.apache.org/bugzilla/show_bug.cgi?id=32619.
> 
> Stephen listed the following as smelling:
> 
> -------
> 1)
> - ArrayUtils.lastIndex()
> Gets the last valid index of an array. Surely users would just call
> getLength() - 1?
> 
> 2)
> - ClassUtils.CLASS_NAME_COMPARATOR
> - ClassUtils.PACKAGE_NAME_COMPARATOR
> Although potentially useful, they seem quite specific. What about
> comparing
> packages using Class objects? (I've never used a Package object in my
> work)
> Or comparing just the short name of a class?
> 
> 3)
> - NotImplementedException
> This now implements Nestable, with a lot of extra methods. None of the
> other
> exception classes in the main package have been changed. We should
> revert
> this change, or find a lighter weight solution that works with
> ExceptionUtils.
> 
> 4)
> - Validate.allElementsOfClass
> Should rename to allElementsOfType, and use instanceof style check, not
> class equals style check
> 
> Still TODO:
> 5)
> - WordUtils
> Capitalize with separator methods need to define null handling for
> delimiter
> list, and better javadoc for two of the three methods
> 
> 6)
> - time.DurationFormatUtils (complete?)
> 7)
> - time.StopWatch (complete?)
> 8)
> - text subpackage (not in 2.1)
> ---------
> 
> I think we were all agreed on 8. 6+7 I'm open to ideas on
> improvements, I think they were complete but need to look again to
> convince myself.
> 
> 3, 4 and 5 all look to be quite agreeable and so just need to be done.
> 
> 1 and 2 look to be "justify thy existence" questions to the relevant
> features. So we need to decide whether we think they should go or not.
> 
> 1 seems to be a classic "it's semantically better" argument, whereas 2
> seems to be a "it's not generic enough". Usually we keep code with
> semantically better arguments and drop not-generic enough code I
> think, so 1 would stay and 2 would be rm'd. I'm not tied to either
> though, so ymmv.
> 
> I've clovered and uploaded to:
> http://www.apache.org/~bayard/commons-lang-2.1/clover/
> 
> Thoughts?
> 
> Hen
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: commons-dev-help@jakarta.apache.org
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: commons-dev-help@jakarta.apache.org
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: commons-dev-help@jakarta.apache.org
> 
>

---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message