commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eric Pugh" <ep...@upstate.com>
Subject RE: [configuration] getProperty vs getPropertyDirect
Date Fri, 03 Dec 2004 11:07:07 GMT
Per my other email, can we use a better name?  maybe something like
interpolateProperty?  It doesn't have to be a JavaBean style getter since we
don't expect it to be called by external tools..

> -----Original Message-----
> From: Emmanuel Bourg [mailto:smanux@lfjr.net]
> Sent: Friday, December 03, 2004 10:16 AM
> To: Jakarta Commons Developers List
> Subject: Re: [configuration] getProperty vs getPropertyDirect
>
>
> Sorry Olivier I should have waited a bit more before comiting the change
> :/ I have no problem reintroducing getPropertyDirect at a later time if
> you find an interesting use case.
>
> Emmanuel Bourg
>
>
> Oliver Heger wrote:
> > After seeing the commit mails I may be a bit late.
> >
> > I had some ideas about extending the interpolation mechanism to support
> > other data types than string, too. For this use case the separation of
> > getProperty() and getPropertyDirect() would be nice, as getProperty()
> > being a generic hook that allows for manipulation of properties (like
> > interpolation) before they are delivered to the caller.
> >
> > But this was nothing concrete yet.
> >
> > Oliver
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: commons-dev-help@jakarta.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message