commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Phil Steitz <>
Subject Re: [math] RC2 Release Plan
Date Sun, 10 Oct 2004 15:10:08 GMT
Phil Steitz wrote:

> 4) Add the following new methods to both RealMatrix and BigMatrix 
> interfaces: RealMatrix getSubMatrix (int startRow, int endRow, int
> startColumn, int endColumn) RealMatrix getSubMatrix (int[] rows, int[]
> columns) RealMatrix getRowMatrix(int row) RealMatrix
> getColumnMatrix(int row) RealMatrix createRowMatrix(double[] row) 
> RealMatrix createColumnMatrix(double[] column)
Any objections to putting the last two methods above in a MatrixUtils
class and change the names to "makeXxx"?

  * A collection of static methods that operate on or return matrices.
  * @version $Revision$ $Date$
public class MatrixUtils {
   public static RealMatrix makeColumnRealMatrix(double[] columnData) ...
   public static RealMatrix makeRowRealMatrix(double[] rowData)

This class would also house corresponding methods for BigMatrix.


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message