commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Phil Steitz <p...@steitz.com>
Subject [math] RC2 Release Plan
Date Sun, 03 Oct 2004 21:42:45 GMT
Based on the comments on RC1, (mostly on this thread:
http://nagoya.apache.org/eyebrowse/BrowseList?listName=commons-dev@jakarta.apache.org&by=thread&from=889687),
I propose that we include the following changes in RC2:

1) Rename .univariate to .descriptive and .multivariate to .regression

2) Add a (writable) boolean "isBiasCorrected" property to Variance and 
StandardDeviation and add constructors to set this property. Make the 
default value true (standard, bias-corrected formula is used).

3) Remove all of the setXxx methods from the RealMatrix and BigMatrix 
interfaces and from the corresponding implementations. getData remains 
with copy semantics and getDataRef can remain in the implementation 
classes (no change - it was never in the interface).

4) Add the following new methods to both RealMatrix and BigMatrix interfaces:
RealMatrix getSubMatrix (int startRow, int endRow, int startColumn,
int endColumn)
RealMatrix getSubMatrix (int[] rows, int[] columns)
RealMatrix getRowMatrix(int row)
RealMatrix getColumnMatrix(int row)
RealMatrix createRowMatrix(double[] row)
RealMatrix createColumnMatrix(double[] column)

Have I missed or misrepresented anything?

I am working on these more or less in the order presented. I have 1) and 
2) done locally modulo some cleanup. Patches / help welcome on the other 
tasks ;-) Remember that we need to make appropriate changes to tests, 
javadoc and user guide and to update changes.xml.

Phil

---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message