commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gary Gregory" <ggreg...@seagullsoftware.com>
Subject RE: [lang] ArrayUtils.lastIndex
Date Sat, 09 Oct 2004 23:53:29 GMT
> I don't have a vote, but, if I did, 

Well constructed arguments are always welcome, no matter which side of
the debate you fall on ;-)

Just to give a concrete ArrayUtils example of what this would look like
for an existing method:

    public static int indexOf(float[] array, float valueToFind, int
startIndex) {
        if (ArrayUtils.isEmpty(array)) {
            return NOT_FOUND;
        }
        if (startIndex < 0) {
            startIndex = 0;
        }
        for (int i = startIndex; i < array.length; i++) {
            if (valueToFind == array[i]) {
                return i;
            }
        }
        return NOT_FOUND;
    }

which makes it pretty clear IMO that you are returning a *well-known*
value (whatever NOT_FOUND is) for a well-defined purpose; as opposed to
seing "-1" and wondering, why not -2 or -3.

Gary

> -----Original Message-----
> From: Michael McGrady [mailto:mike@michaelmcgrady.com]
> Sent: Saturday, October 09, 2004 14:53
> To: Jakarta Commons Developers List
> Subject: Re: [lang] ArrayUtils.lastIndex
> 
> I don't have a vote, but, if I did, I would vote very high in favor of
> all such decisions.  Hard coding is not good for lots of reasons, in
my
> opinion.  If the -1s mean the same thing "all over the place", then
they
> should be identified as to what they mean in all places with the value
> put in one place.  In my opinion, this is one of the more valuable
knee
> jerks we should have.
> 
> Michael McGrady
> 
> Gary Gregory wrote:
> 
> >Speaking of "-1"s. I wonder if we should create a constant for the
"-1
> >means NOT_FOUND" concept. This value is hard coded all over the place
in
> >ArrayUtils. It seems to me like it would make the code more readable.
> >
> >Gary
> >
> >
> >
> >>-----Original Message-----
> >>From: Stephen Colebourne [mailto:scolebourne@btopenworld.com]
> >>Sent: Saturday, October 09, 2004 04:27
> >>To: Jakarta Commons Developers List
> >>Subject: [lang] ArrayUtils.lastIndex
> >>
> >>ArrayUtils.lastIndex
> >>This method is effectively:
> >>  array.length - 1
> >>with null checks
> >>
> >>This method was added in the 1.41 version of ArrayUtils. I want to
> >>
> >>
> >remove
> >
> >
> >>it, as it really doesn't seem to add any value over and above
> >>
> >>
> >getLength().
> >
> >
> >>The original bug request didn't ask for it either:
> >>http://issues.apache.org/bugzilla/show_bug.cgi?id=26594
> >>
> >>I intend to remove the method unless I hear objections.
> >>
> >>Stephen
> >>
> >>
>
>>---------------------------------------------------------------------
> >>To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
> >>For additional commands, e-mail: commons-dev-help@jakarta.apache.org
> >>
> >>
> >
> >
> >---------------------------------------------------------------------
> >To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
> >For additional commands, e-mail: commons-dev-help@jakarta.apache.org
> >
> >
> >
> >
> >
> >
> 
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: commons-dev-help@jakarta.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message