commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Al Chou <hotfusion...@yahoo.com>
Subject Re: [math] RC2 Release Plan
Date Sun, 10 Oct 2004 20:06:40 GMT
--- Phil Steitz <phil@steitz.com> wrote:
> Phil Steitz wrote:
> 
> > 4) Add the following new methods to both RealMatrix and BigMatrix 
> > interfaces: RealMatrix getSubMatrix (int startRow, int endRow, int
> > startColumn, int endColumn) RealMatrix getSubMatrix (int[] rows, int[]
> > columns) RealMatrix getRowMatrix(int row) RealMatrix
> > getColumnMatrix(int row) RealMatrix createRowMatrix(double[] row) 
> > RealMatrix createColumnMatrix(double[] column)
> > 
> Any objections to putting the last two methods above in a MatrixUtils

No objection, that makes sense to me.


> class and change the names to "makeXxx"?

Despite being longer, I like the originally proposed method names better.



Al

---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message