commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stephen Colebourne" <>
Subject [lang] Review for 2.1
Date Fri, 08 Oct 2004 00:29:47 GMT
Add prefix...
Based on JDiff -
I'm not sure I like the following changes in 2.1:

- ArrayUtils.lastIndex()
Gets the last valid index of an array. Surely users would just call
getLength() - 1?

Although potentially useful, they seem quite specific. What about comparing
packages using Class objects? (I've never used a Package object in my work)
Or comparing just the short name of a class?

- NotImplementedException
This now implements Nestable, with a lot of extra methods. None of the other
exception classes in the main package have been changed. We should revert
this change, or find a lighter weight solution that works with

- Validate.allElementsOfClass
Should rename to allElementsOfType, and use instanceof style check, not
class equals style check

Still TODO:
- WordUtils
Capitalize with separator methods need to define null handling for delimiter
list, and better javadoc for two of the three methods

- DurationFormatUtils
Still needs more work

- StopWatch
Is this complete?

- text subpackage

Things I'm happy with:
- CharEncoding
- CharUtils
- other ArrayUtsls additions (although the class is large now)
- ObjectUtils changes
- StringUtils changes
- SystemUtils changes
- Builder package changes
- Enum rename to Enums
- Mutable subpackage
- NumberUtils changes
- DateUtils changes

My thought is maybe we can do a release soon without the text subpackage?
And possibly with DurationFormatUtils still package scoped. We now have a
customer (cocoon) wanting a release, so we should try and oblige.


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message