commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <farhan.ah...@oocl.com>
Subject Help with using commons-email
Date Tue, 07 Sep 2004 14:40:43 GMT
Hi all,

I'm a newbie, so please forgive me if this problem has already been addressed. I downloaded
the commons-email from the Sandbox and wanted to try it out; but I could not get the example
for the SimpleMail working. I kept getting the following error:

	Exception in thread "main" java.lang.NoClassDefFoundError: javax/mail/MessagingException
        		at SimpleMail.main(SimpleMail.java:10)

I have checked my Classpath multiple times and I have javamail-1.3.1 and jaf-1.0.2 and commons-lang
in my classpath (using JDK 1.4.2_05 SE). So I wrote a simple email sender program without
using the commons-email and it worked without a hitch (I'm using Eclipse 3 as my IDE).

So I guess, what I want to know is this a problem with the commons-email or is there something
I am not doing.

Thanks for all the help.

Regards,
Farhan


IMPORTANT NOTICE
Email from OOCL Logistics is confidential and may be legally privileged.  If it is not intended
for you, please delete it immediately unread.  The internet cannot guarantee that this communication
is free of viruses, interception or interference and anyone who communicates with us by email
is taken to accept the risks in so doing.  Without limitation, OOCL Logistics and its affiliates
accept no liability whatsoever and howsoever arising in connection with the use of this email.
 Under no circumstances shall this email constitute a binding agreement for provision of services
by OOCL Logistics, which is subject to the standard terms and conditions of OOCL Logistics.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message