commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Phil Steitz" <>
Subject RE: [math] API changes for RC2
Date Mon, 27 Sep 2004 17:26:56 GMT
What I meant was, "is it a good idea to remove getData, getDataRef?"  If we do that, people
who want to work directly on the double[][] arrays after, say inversion will be SOL.  Maybe
names are wrong, but we probably need to keep an "export" capability of some sort.

	-----Original Message----- 
	From: Mark R. Diggory [] 
	Sent: Mon 9/27/2004 10:18 AM 
	To: Jakarta Commons Developers List 
	Subject: Re: [math] API changes for RC2

	Phil Steitz wrote:
	> Mark,
	> I see your point re RealMatrix immutability and I now understand (and
	> agree with, I think) what you mean about accessors.  Can anyone else
	> see reasons why  matrices should *not* be publicly immutable?  Would
	> you also remove the getData, getDataRef methods?
	> Phil
	Sure, I can make these changes.
	Mark Diggory
	Software Developer
	Harvard MIT Data Center
	To unsubscribe, e-mail:
	For additional commands, e-mail:

View raw message