commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Oleg Kalnichevski <ol...@bluewin.ch>
Subject Re: HTTP Client File Upload Question
Date Thu, 23 Sep 2004 17:51:31 GMT
Nigel,

Try setting Parts' transfer-encoding and charset to null and see if that
makes any difference.

http://jakarta.apache.org/commons/httpclient/apidocs/org/apache/commons/httpclient/methods/multipart/PartBase.html#setTransferEncoding(java.lang.String)

Oleg


On Thu, 2004-09-23 at 14:05, Nigel Rantor wrote:
> Hi all,
> 
> I'm being bitten by a weird bug and I have a feeling it's because I'm 
> not sure about content-transfer encodings vs charsets.
> 
> I'm using httpclient 2 to upload to a perl CGI.
> 
> Uploading from a browser works fine.
> 
> Uploading from my program works fine for text files.
> 
> Uploading from my program fails for binary files. The resulting file is 
> corrupted, it seems as if the two high bits of every byte have been 
> zeroed, so a byte val of FF gets transferred as 3F.
> 
> Does this make any sense to anyone?
> 
> TIA,
> 
>    N
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: commons-dev-help@jakarta.apache.org
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message