commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eric Pugh" <ep...@upstate.com>
Subject [Configuration] XML Processing Problem
Date Tue, 10 Aug 2004 08:55:29 GMT
Hi all,

After removing the ConfigurationXMLDocument  I am down to two bugs.  Right
now the testSave method of TestXmlConfiguration fails on the array check
when testing XmlConfiguration.  The reason is that this line:

CharacterData data = document.createTextNode((String) value); seems to be
adding array elements into one string versus multiple elements.  The XML
should look like:

 <test>
          	<array>value1</array>
		<array>value2</array>
		<array>value3</array>
		<array>value4</array>
</test>

However, it looks like:
 <test>
         <array>value1value2value3value4</array>
</test>



The same basic problem occurs with this loop:
        // add an array of strings in an attribute
        for (int i = 1; i < 5; i++)
        {
            conf.addProperty("test.attribute[@array]", "value" + i);
        }

However, in this case, instead of add value1, value2, etc:
 <test>
          	<attribute array="value1"/>
          	<attribute array="value2"/>
          	<attribute array="value3"/>
          	<attribute array="value4"/>
</test>

we get just:
 <test>
          	<attribute array="value4"/>
</test>


Any suggestions on how to fix this?  I am somewhere deep down in private
void setXmlProperty(String name, Object value) and quite lost!

Eric




---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message