commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Simon Kitching <si...@ecnetwork.co.nz>
Subject Re: Digester
Date Thu, 15 Jul 2004 04:38:10 GMT
On Thu, 2004-07-15 at 16:08, John Kane wrote:
> Hi
> 
> I hit a minor problem with commons digester 1.5.
> 
> The version of digester I'm using is the version Struts 1.1
> 
> I read an XML file that contains the following tag definition
> 
> <some-tag optional="true">
> 
> On Windows XP it read the value correctly.  However, when I've ported this 
> to Solaris the value does not get read it any longer.
> 
> Just wonder where the actual problem is.
> 
> Digester ?
> SAX ?
> XERCES?
> Java Beans?
> 
> Currently searching the bug database but can find any related info.

I'm not aware of anyone experiencing this issue before.

I think you need to narrow down the possible causes.

The first thing to do is probably to enable Digester logging, and see if
the output gives any clues. See
   http://wiki.apache.org/jakarta-commons/Digester/FAQ
for information on how to enable logging in Digester.

If this shows that the attribute is not being seen, then I suggest
creating a simple program that directly uses SAX, and see whether the
XML parser is reporting the attribute.

By the way, this question is probably better asked on the user list than
the developer list. 

Regards,

Simon


---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message