commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mario Ivankovits <ima...@apache.org>
Subject [vfs][all][poll]regular expression library or jdk1.4 as minimum requirement
Date Mon, 14 Jun 2004 09:23:19 GMT
Hello!

A contribution of Rami Ojares brings in an "PatternSelector" to handle 
ant-style patterns (/dir/**/file) to select files.
This class currently uses the jdk1.4 regular expression library.

Now there are some questions how to handle the regexp thing:
[ ] Avoid dependency to jdk1.4.
[ ] ... use jakarta-regexp
[ ] ... use jakarta-oro
[ ] ... use the regexp bundled with ant. But then we could not use the 
PatternSelector without the ant.jar and have to move it to the vfs.ant 
package. This powerfull thing might then not be useable for projects 
without it.

[ ] Dont bother and use jdk1.4 as minimum requirement (and its regexp)


Here is my vote:
[X] Dont bother and use jdk1.4 as minimum requirement
But i dont know which jdk version will be the most used and this is why 
i started this poll.
IMHO at least for a sandbox component it should be permitted to use this 
"bleeding edge ;-)" jdk-version.


PS: During writing of this poll, i noticed that there already two 
dependencies to the jdk1.4, but those can be easily reverted.

-- 
Mario


---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message