commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 29684] New: - BeanUtils copyProperties does not copy if theres a digit in property name
Date Fri, 18 Jun 2004 22:17:17 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=29684>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=29684

BeanUtils copyProperties does not copy if theres a digit in property name

           Summary: BeanUtils copyProperties does not copy if theres a digit
                    in property name
           Product: Commons
           Version: 1.6 Final
          Platform: All
        OS/Version: Other
            Status: NEW
          Severity: Major
          Priority: Other
         Component: Bean Utilities
        AssignedTo: commons-dev@jakarta.apache.org
        ReportedBy: live216@yahoo.com


If dest has two properties, say P1NAME and P2NAME, with setter methods
setP1NAME(String ... and setP2NAME(String ... then the properties from orig will
not be copied from orig to dest.

In my particular case orig is a DynaActionBean and dest is a custom bean. If
P1NAME is changed to PNAME, then the copy properties works.

---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message