commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 29454] - No compile under J2SDK 1.3
Date Thu, 10 Jun 2004 06:27:11 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=29454>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=29454

No compile under J2SDK 1.3





------- Additional Comments From agallardo@agsoftware.dnsalias.com  2004-06-10 06:27 -------
Perhaps I don't explain myself good enough. I mean:

How to build the library that will run on java 1.3 and 1.4. and use JDBC 2.0 or
3.0 for general use?

For example if we will distribute the lib in a package as OJB or Cocoon?

AFAIK, there is a common limitation in some javac versions of 1.4 that cannot
run on java 1.3

The key is to avoid using API introduced since version 1.4 And seems this is not
the case since you are providing a patch for that.

Limiting a build just to JDBC 2.0 is just a workaround and not a solution from
my POV.

Anyway, if you think the bug is resolved and fixed, it is ok. I was just trying
to point to a problem. I use J2SDK 1.4, the cencerns was just for back
compatibility.

---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message