commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Karasulu <>
Subject Re: [testutils] Is there any commons area for generic test code?
Date Fri, 11 Jun 2004 14:55:33 GMT
> contrary to as someone pointed out on this thread I think this subject 
> is very exciting.  For my development projects I have also founded a 

Sorry man I did not mean to insult those who are religious about testing
when I said it was boring.  It's just not my favorite topic although I
do enjoy it.

>   - Assertions for common issues: instanceof, thrown exceptions, array 
> element equality etc.
>   - Threading: validate error free execution and termination of threads.
>   - Futures: constraints Future objects.
>   - Beans: validate property accessors and property change events.
>   - DataObject: validate implementation of equals, hashCode and 
> serialization.
>   - Logging: add log interface to TestCase
>   - Watchdog: terminate test after maximum execution time.

Sounds like good stuff.  If you're already a committer why not add your

> This is all to say that I encourage the effort to found the sandbox 
> project.  I will try to contribute from these if suitable once the test 
> project materializes.

Oh the sandbox project has already been created.  Both Oliver and I have
started adding to it already.

> For these extensions dependencies on Logging, BeanUtils and even 
> Functors have been introduced.
> I do not see the need to avoid dependency in a test-utils project. 
> Test-utils are used during the development and are usually not part of 
> the developed product.  I would not put the minimization of dependencies 
> too high on the agenda, as the testing has a different scope.

That's actually a very good point!  These dependencies are shed and do
not come with the project deliverable.  Let's do away with that criteria

> For the name, IMO 'testutils' is a better choice than 'test' as it 
> provides for less ambiguity.  Maybe even the focus on UnitTesting should 
> be highlighted: 'unittestutils'.

Actually I was thinking more than just unit testing.  It could contain
code to build harnesses and such for things like stress tests and
integration tests.  Also there is the shorter package name although this
is not the driving factor of course :-).  If others want to change the
name too then we can do it.  See if you can reach consensus on it.

Good to see your interest.


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message