commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Noel J. Bergman" <n...@devtech.com>
Subject RE: [net] minimum jdk version?
Date Fri, 07 May 2004 05:42:36 GMT
> BTW, you should always compile the release jar on JDK1.3,
> as a 1.4 built one often doesn't run on JDK 1.2/1.3.

> Do you have a reference to this documented somewhere?  I had not heard
this.

I'm not going to look up specific methods, but the issue is that if JDK 1.3
has a method Class#f(Object), and JDK 1.4 has Class#f(Derived), then the
following is not compatible: f(new Derived).  The later JDK would use the
more specific method signature, which will not be present in the earlier
JRE, so you must compile with the older JDK.

	--- Noel


---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message