commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Noel J. Bergman" <n...@devtech.com>
Subject RE: [logging][PROPOSAL] a solution to incompatibility between log4j versions
Date Wed, 19 May 2004 19:28:01 GMT
> Which is why GUMP should allow projects to specify dependencies
> on SPECIFIC versions of other products....

A project may want to track the latest FOO, which forces it to pickup a
newer BAR, too, even though its own use of BAR might want to stay stable.
There are all sorts of possibly dependency relationships.

And you do want GUMP to warn you about pending problems.  You just also
might want it to try to do as much building, using backlevel versions if
necessary, as it can.

	--- Noel


---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message