commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Edelson, Justin" <Justin.Edel...@mtvi.com>
Subject [net] minimum jdk version?
Date Tue, 04 May 2004 18:06:53 GMT
Does the net 1.2 require JDK 1.4 to compile? The only documentation that
mentions it (that I've found) is the Release Notes for 1.1.1, which
claim that future versions (>1.2) will require JDK 1.2. It's unclear
whether this is for compilation or at runtime.

However, net 1.2 won't compile against anything prior to 1.4 (I'm
working with 1.3.1) because
org.apache.commons.net.ftp.parser.NTFTPEntryParser tries to call
Calendar.getTimeInMillis() on line 132, which prior to 1.4 was a
protected method.



---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message