commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stephen Colebourne <scolebou...@btopenworld.com>
Subject Re: [net] minimum jdk version?
Date Wed, 05 May 2004 11:52:13 GMT
 --- "Jeffrey D. Brekke" <jbrekke@wi.rr.com> wrote: >
>>>>> On Tue, 04 May 2004 23:35:18 +0100, Stephen
> Colebourne <scolebourne@btopenworld.com> said:
> 
> > 1.2.1 looks likely.  BTW, you should always
> compile the release jar
> > on JDK1.3, as a 1.4 built one often doesn't run on
> JDK 1.2/1.3.
> 
> Do you have a reference to this documented
> somewhere?  I had not heard this.  I was under the
> impression that, aside from new classes, it should
> work with the correct compiler switch.  Maven
> defaults to -source 1.3 -target 1.1 I believe.

Experience building [collections] with 1.4 and then
running the tests in 1.3, caused issues.

The problem lies with the fact that, although the
bytecode format may be generated correctly, the JDK
API may have additional methods. If the compilation
links to a JDK 1.4 only method, it won't run on 1.3.

Stephen


---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message