commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rob Oxspring <roxspr...@imapmail.org>
Subject [CLI] final 2.0 repackaging
Date Mon, 29 Mar 2004 13:10:29 GMT
I've been looking at how to resolve the jdepend test failure without 
taking the ignoring approach (up the threshold to 0.3).  I went in 
search of a way to package things better and after thinking it through I 
came up with the following proposed renamings:

1) o.a.c.c.HelpFormatter -> o.a.c.c.util.HelpFormatter
HelpFormatter strikes me as "quite useful but non-essential" which 
pretty much describes most .util packages. (My initial thought was for a 
.help package but nothing else seemed to fit with it)

2) o.a.c.c.HelpSetting -> o.a.c.c.DisplaySetting
HelpSetting is used outside of the help context (i.e. toString()) and 
all the constants are prefixed DISPLAY_ anyway.

3) o.a.c.c.impl.Comparators -> o.a.c.c.util.Comparators
I searched for candidates to join HelpFormatter and Comparators struck 
me as "quite useful but non-essential" too.

4) o.a.c.c.impl -> o.a.c.c.options
After 3, .impl is composed of 9 Option implementations and HelpLineImpl 
which is just part of the Option implementation anyway.  Also I wonder 
if people will avoid touching / investigating .impl packages (as I do) 
and miss PropertyOption.

5) DefaultOption* -> Flag*
I still have a slight itch about the name 'DefaultOption' and 'Flag' is 
the best alternative I can remember coming up with.


I think 2 should definitely be done and am fairly sure that 5 is a step 
forward (anything better than Flag out there??).  I'm increasingly 
comfortable that 1 & 3 make sense to be done together, and 4 is just the 
logical conclusion.

Actually though, the choice of .options vs .option might open another 
can of worms; should packages be singular or plural.  I think we should 
rename .builders or .commandline if we come to a decision.  Personally 
plural seems better but I prefer .util to .utils - so I've got double 
standards internally anyway and could be persuaded either way.

Back to the original point, doing 1 & 3 brings the jdepend distance to a 
maximum of ~0.20 so we can up the threshold to 0.21 and the test will 
pass too.

Thoughts?

Rob

---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message