commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Al Chou <hotfusion...@yahoo.com>
Subject Re: [math][proposal] stat package structure
Date Mon, 22 Mar 2004 03:40:01 GMT
--- Phil Steitz <phil@steitz.com> wrote:
> I would like to propose the following repackaging of classes in the stat 
> and distributions packages.
> 
> 1. Move the univariate statistical aggregates (DescriptiveStatistics, 
> SummaryStatistics et al) into the univariate package.

+1


> 2. Move distributions back into stat. I did not comment on the initial 
> move out, but it seems wrong to me now.  The abstract classes and all 
> implementations are probability distributions. To me these fit naturally 
> in stat.  I can live with it as is; I just wanted to see if others are 
> feeling the same and if so, get it fixed while we still have the chance.

+1  Here the "stat" package doubles as a "probability" package that doesn't
exist, but in the absence of a use case for the latter, it makes sense to make
the move you're proposing.


> 3. Create a "multivariate" subpackage and place the lonely 
> BivariateRegression there.  It is odd to have a package with only one 
> class, but I think the probability is 1 that we will quickly have more 
> multivariate statistical classes (e.g. multiple regression) and I would 
> prefer not to have to play the deprecate-move game if we can see it coming.

+1  It's like a section of a document outline that has only one subsection
(which my English teachers in secondary schools always warned against <g>),
except that we can easily envision other subsections coming into existence
under that section.


> 4. Similarly, I would like to create an "inference" or "test" subpackage 
> and put TestStatistic there.

+1  I wonder if there's a better name than those two.  I see Mark voted for
"test", but -- perhaps because I've never done much statistics -- that makes me
think that I'm looking at a JUnit "tests" directory tree.  A quick skim through
_NR_ chapter 14 didn't turn up any better names, though.

While you're moving TestStatistic, I noticed two typos in the Javadoc for
chiSquare( double[, double[] ):  "freqeuncy" and "counds".



Al

__________________________________
Do you Yahoo!?
Yahoo! Finance Tax Center - File online. File on time.
http://taxes.yahoo.com/filing.html

---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message