commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mark R. Diggory" <>
Subject Re: [math][proposal] stat package structure
Date Mon, 22 Mar 2004 16:44:14 GMT
On Sun, 2004-03-21 at 22:40, Al Chou wrote:
> --- Phil Steitz <> wrote:
> > I would like to propose the following repackaging of classes in the stat 
> > and distributions packages.
> > 
> > 1. Move the univariate statistical aggregates (DescriptiveStatistics, 
> > SummaryStatistics et al) into the univariate package.
> +1
> > 2. Move distributions back into stat. I did not comment on the initial 
> > move out, but it seems wrong to me now.  The abstract classes and all 
> > implementations are probability distributions. To me these fit naturally 
> > in stat.  I can live with it as is; I just wanted to see if others are 
> > feeling the same and if so, get it fixed while we still have the chance.
> +1  Here the "stat" package doubles as a "probability" package that doesn't
> exist, but in the absence of a use case for the latter, it makes sense to make
> the move you're proposing.

> > 3. Create a "multivariate" subpackage and place the lonely 
> > BivariateRegression there.  It is odd to have a package with only one 
> > class, but I think the probability is 1 that we will quickly have more 
> > multivariate statistical classes (e.g. multiple regression) and I would 
> > prefer not to have to play the deprecate-move game if we can see it coming.
> +1  It's like a section of a document outline that has only one subsection
> (which my English teachers in secondary schools always warned against <g>),
> except that we can easily envision other subsections coming into existence
> under that section.
> > 4. Similarly, I would like to create an "inference" or "test" subpackage 
> > and put TestStatistic there.
> +1  I wonder if there's a better name than those two.  I see Mark voted for
> "test", but -- perhaps because I've never done much statistics -- that makes me
> think that I'm looking at a JUnit "tests" directory tree.  A quick skim through
> _NR_ chapter 14 didn't turn up any better names, though.

good point, although we avoid "test" package names for JUnit tests in
favor of the original package name of the class being tested, something
I think is very smart to do. I'm not too picky here, I just picked test
because its shorter, inference is more descriptive too. Along the same
lines "distributions" could be confused with the the generic idea of a
"distribution" of packages directory, maybe "probability is better

Maybe it should be organized more along the following lines?


> While you're moving TestStatistic, I noticed two typos in the Javadoc for
> chiSquare( double[, double[] ):  "freqeuncy" and "counds".

Mark R. Diggory
Software Developer - VDC Project
Harvard MIT Data Center

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message