commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Todd V. Jonker" <>
Subject RE: Proposal for the Commons Sandbox
Date Tue, 09 Mar 2004 17:53:28 GMT
In describing the idiom, Gary used the word "Assists".   "Assistant"
would be a very nice name for this pattern.

I agree that "builder" is misleading, since what's going on here is very
different from the GOF (and therefore de facto standard) meaning.


On Mon,  8 Mar 2004 16:19:05 -0500, "David Gilliland"
<> said:
> The classical GOF Builder pattern is the definition of "builder" I am
> most familiar with.  The definition embodied in "EqualsBuilder" is a
> different one, however, though I agree it's exceptionally difficult to
> come up with a name that means what we want here but that does not
> already have some overloaded meaning (logical candidates like "Helper" or
> "Utils" already have particular meanings).

> >On Mon, 8 Mar 2004, Gary Gregory wrote:
> >> For the package as a whole, the term builder applies to the notion of
> >> building different kinds of algorithms for us with toString(), equals(),
> >> compareTo(), and hashCode(). Builder might not be a great name but it is
> >> hard to think of a name that says: "Assits in overriding methods that
> >> are in Object: toString(), hashCode(), equals(), and also compareTo()."

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message