commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 27159] New: - LRUMap.clone() broken?
Date Mon, 23 Feb 2004 14:21:37 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=27159>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=27159

LRUMap.clone() broken?

           Summary: LRUMap.clone() broken?
           Product: Commons
           Version: 3.0 Final
          Platform: Other
        OS/Version: Other
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: Collections
        AssignedTo: commons-dev@jakarta.apache.org
        ReportedBy: fgiust@sapient.com


LRUMap.clone() always produces an empty Map. Shouldn't it produce a shallow 
copy with all the entries?

This test actually fails in 3.0:

    public void testLRUMapClone()
    {
        LRUMap lru = new LRUMap(10);
        lru.put("1", "1");

        Map lruClone = (Map) lru.clone();

        assertEquals(lru.size(), lruClone.size());
    }

---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message