commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Todd V. Jonker" <>
Subject Re: [lang] split & join
Date Mon, 16 Feb 2004 21:47:54 GMT
Stick with split, otherwise users will have to remember the difference
between split and divide or chop or hack or cut or slice or some other
arbitrary word.  The slight semantic difference is far from obvious in
the name.

This is why I am constantly digging through the [lang] API docs to
remember the difference between (for example) clean() and trim() and 
strip().  There are subtle semantic differences hidden, none of which are
indicated by the method names, which are all equally arbitrary and
generic.  I find it continually frustrating.  Let's not make that mistake


On Thu, 12 Feb 2004 19:08:29 +0100, "Emmanuel Bourg"
<> said:
> Joe Germuska wrote:
> > Maybe the best would just be an alternate method signature to split(...) ?
> This solution is a bit ugly i think, but it's the only one if we can't 
> find a better name. What about divide(), break() or cut() ?
> Emmanuel Bourg

Todd V. Jonker

Conscious Code Ltd
The Practice of Programming

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message