commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From scolebou...@btopenworld.com
Subject Re: [uid] Uuid
Date Mon, 05 Jan 2004 13:05:04 GMT
I can understand this POV, but I favour FTPUNIXXMLThing. In our example here, UUIDFactory just
seems better than UuidFactory to me.

Stephen

>  from:    __matthewHawthorne <matth@phreaker.net>
> Gary Gregory wrote:
> > I prefer treating acronyms as words (Uuid), which avoids IMO silly and
> > *unreadable* names like FTPUNIXXMLThing in favor or FtpUnixXmlThing.
> > 
> > Gary 
> 
> 
> I agree.  Once you have a class with more than 1 acronym in the name, 
> things get out of hand.  I feel that this is a nice consistent approach 
> to producing readable names.


---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message