commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gary Gregory <ggreg...@seagullsw.com>
Subject RE: [uid] Uuid
Date Mon, 05 Jan 2004 18:36:35 GMT
In the case of factories, I think what really matters is that the Widget
names match exactly between WidgetFactory and Widget, in this case, UUID and
UUIDFactory or Uuid and UuidFactory. I guess we can agree to disagree since
a compromise does not seem possible :-(

Gary

> -----Original Message-----
> From: scolebourne@btopenworld.com [mailto:scolebourne@btopenworld.com]
> Sent: Monday, January 05, 2004 05:05
> To: commons-dev@jakarta.apache.org
> Subject: Re: [uid] Uuid
> 
> I can understand this POV, but I favour FTPUNIXXMLThing. In our example
> here, UUIDFactory just seems better than UuidFactory to me.
> 
> Stephen
> 
> >  from:    __matthewHawthorne <matth@phreaker.net>
> > Gary Gregory wrote:
> > > I prefer treating acronyms as words (Uuid), which avoids IMO silly and
> > > *unreadable* names like FTPUNIXXMLThing in favor or FtpUnixXmlThing.
> > >
> > > Gary
> >
> >
> > I agree.  Once you have a class with more than 1 acronym in the name,
> > things get out of hand.  I feel that this is a nice consistent approach
> > to producing readable names.
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: commons-dev-help@jakarta.apache.org

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message